Skip to content
MediumVulnerabilityLLM-specific

CVE-2026-43995: Flowise tools bypass secured wrapper and invoke raw HTTP clients

Identifier
CVE-2026-43995
Published
Record updated
View JSON
Affected
  • flowise <= 3.0.13
  • flowise-components <= 3.0.13
Fixed in
3.1.0
  • flowise 3.1.0 released March 16, 2026, 56 days before disclosure
  • flowise-components 3.1.0 released March 16, 2026, 56 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.4%

Summary

CVE-2026-43995 affects Flowise, a drag and drop user interface for building customized large language model flows, prior to 3.1.0. Several tool implementations, including OpenAPIToolkit/OpenAPIToolkit.ts, WebScraperTool/WebScraperTool.ts, MCP/core.ts and Arxiv/core.ts, import and invoke raw HTTP clients (node-fetch, axios) instead of the secured wrapper. The weakness is classified as CWE-918, Server-Side Request Forgery. GitHub assigns a CVSS 4.0 base score of 5.3 (MEDIUM).

Mitigation

Fixed in 3.1.0.