Skip to content
MediumVulnerability

CVE-2022-29204: TensorFlow denial of service through UnsortedSegmentJoin num_segments validation

Identifier
CVE-2022-29204
Published
Record updated
View JSON
Affected
  • tensorflow < 2.6.4, fixed in 2.6.4, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.7.0, < 2.7.2, fixed in 2.7.2, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 5 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.4%

Summary

TensorFlow versions before 2.9.0, 2.8.1, 2.7.2 and 2.6.4 fail to fully validate the input arguments of tf.raw_ops.UnsortedSegmentJoin. A negative num_segments value, which is used to allocate the output tensor, triggers a CHECK-failure that can be used to cause a denial of service.

Mitigation

Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.