Skip to content
MediumVulnerability

CVE-2025-66451: LibreChat prompt group PATCH endpoint accepts unvalidated request bodies

Identifier
CVE-2025-66451
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

CVE-2025-66451 affects LibreChat versions 0.8.0 and below. The PATCH endpoint for prompt groups (/api/prompts/groups/:groupId) does not sufficiently validate request bodies, so users can modify prompts in ways the front end does not intend. The patchPromptGroup function passes req.body directly to updatePromptGroup() without filtering sensitive fields.

Mitigation

Fixed in version 0.8.1.