Skip to content
MediumVulnerability

CVE-2022-29197: TensorFlow denial of service through tf.raw_ops.UnsortedSegmentJoin

Identifier
CVE-2022-29197
Published
Record updated
View JSON
Affected
  • tensorflow < 2.6.4, fixed in 2.6.4, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.7.0, < 2.7.2, fixed in 2.7.2, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 5 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

CVE-2022-29197 affects TensorFlow before versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4. The implementation of `tf.raw_ops.UnsortedSegmentJoin` does not fully validate its input arguments, and it assumes `num_segments` is a scalar without checking it before reading its value. This produces a `CHECK`-failure that can be used to trigger a denial of service.

Mitigation

Fixed in TensorFlow versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, which contain a patch for this issue.