Skip to content
MediumVulnerability

CVE-2022-29213: TensorFlow crash from missing input validation in rfft2d and rfft3d

Identifier
CVE-2022-29213
Published
Record updated
View JSON
Affected
  • tensorflow < 2.6.4, fixed in 2.6.4, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.7.0, < 2.7.2, fixed in 2.7.2, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 5 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

CVE-2022-29213 affects TensorFlow versions before 2.9.0, 2.8.1, 2.7.2, and 2.6.4. The tf.compat.v1.signal.rfft2d and tf.compat.v1.signal.rfft3d functions lack input validation, and under certain conditions this can cause crashes from CHECK-failures.

Mitigation

Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.