Skip to content
MediumVulnerability

CVE-2022-35994: TensorFlow denial of service through CollectiveGather with scalar input

Identifier
CVE-2022-35994
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's `CollectiveGather` fails a `CHECK` when it receives a scalar `input`, which an attacker can trigger to cause a denial of service. The issue is tracked as CVE-2022-35994 and affects TensorFlow versions still in the supported range.

Mitigation

Patched in GitHub commit c1f491817dec39a26be3c574e86a88c30f3c4770. The fix will be included in TensorFlow 2.10.0 and cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2.