Skip to content
MediumVulnerability

CVE-2022-35970: TensorFlow segfault in QuantizedInstanceNorm with nonzero-rank x_min or x_max

Identifier
CVE-2022-35970
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's `QuantizedInstanceNorm` segfaults when given `x_min` or `x_max` tensors of nonzero rank, which allows a denial of service attack. The issue affects TensorFlow versions still in supported range, including 2.9.x, 2.8.x and 2.7.x.

Mitigation

Patched in GitHub commit 785d67a78a1d533759fcd2f5e8d6ef778de849e0. The fix is included in TensorFlow 2.10.0 and will be cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2. No known workarounds.