HighVulnerability
CVE-2025-57760: Langflow privilege escalation in containers via langflow superuser CLI command
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2025-57760
- Published
- Record updated
- Affected
- langflow <= 1.5.0, fixed in 1.5.1, released August 28, 2025, 3 days after disclosure
- langflow-base <= 0.5.0, fixed in 0.5.1, released August 28, 2025, 3 days after disclosure
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.5%
Summary
CVE-2025-57760 is a privilege escalation flaw in Langflow containers, a tool for building and deploying AI-powered agents and workflows. An authenticated user with RCE access can run the internal CLI command langflow superuser to create a new administrative user, gaining full superuser access even if they registered through the UI as a regular account. The weakness is classified as CWE-269, Improper Privilege Management.
Mitigation
The source does not state a fix yet. Check the original advisory for updates.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- langflowPyPIReaches an LLM package through dependencies
- langflow-basePyPILLM dependency since 2024-04-01 · 1 tracked dependent
Related items
- MediumCVE-2026-121936: easyVoice server-side request forgery through openaiBaseUrl in /api/v1/ttsSimilar attack · NVD/CVE Database
- MediumCVE-2026-118628: MLflow get-artifacts server-side request forgery information disclosureSimilar attack · NVD/CVE Database
- HighCVE-2026-118625: MLflow Tracking Server privilege escalation via get_endpointsSimilar attack · NVD/CVE Database
- InfoWhen trust becomes the payload: Inside the threats, etc quarterly reportSimilar attack · Elastic Security Labs
- MediumCritical Langflow flaws enable authentication bypass and RCESimilar attack · CSO Online