CriticalVulnerability
CVE-2023-36281: langchain remote code execution through JSON file in load_prompt
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2023-36281
- Published
- Record updated
- Affected
- langchain < 0.0.312
- Fixed in
- 0.0.312
- released October 10, 2023, 49 days after disclosure
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 3.4%
Summary
CVE-2023-36281 affects langchain v0.0.171. A remote attacker can execute arbitrary code by supplying a crafted JSON file to load_prompt, related to __subclasses__ or a template. The weakness is classified as CWE-94 (Improper Control of Generation of Code).
Mitigation
Fixed in v0.0.312, per the release tag referenced in the source (https://github.com/langchain-ai/langchain/releases/tag/v0.0.312).
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- langchainPyPILLM dependency since 2022-10-25 · 31 tracked dependents
Related items
- MediumGHSA-8prr-f582-jqq3: LangGraph CLI prints the registry push token in `langgraph deploy --verbose` outputSame vendor · GitHub Advisory Database
- HighGHSA-4hm6-w6qq-w73v: LangGraph JavaScript custom authentication may permit cross-user Store accessSame vendor · GitHub Advisory Database
- MediumGHSA-3fx2-cqw9-xr3c: LangGraph: Unencoded identifiers in LangGraph SDK v3 streaming can redirect authenticated GET requestsSame vendor · GitHub Advisory Database
- MediumGHSA-6hmw-9432-67qq: LangGraph: Namespace labels containing `.` reach other namespaces in Postgres and SQLite storesSame vendor · GitHub Advisory Database
- MediumCVE-2026-108575: BerriAI LiteLLM improper authorization in secret resolution via api_keySame vendor · NVD/CVE Database