Skip to content
MediumVulnerability

CVE-2022-35974: TensorFlow denial of service via nonscalar inputs to QuantizeDownAndShrinkRange

Identifier
CVE-2022-35974
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2022-35974 affects TensorFlow. When `QuantizeDownAndShrinkRange` receives nonscalar inputs for `input_min` or `input_max`, it causes a segfault that can be used to trigger a denial of service attack.

Mitigation

Patched in GitHub commit 73ad1815ebcfeb7c051f9c2f7ab5024380ca8613. The fix will be included in TensorFlow 2.10.0 and cherry-picked to TensorFlow 2.9.1, 2.8.1, and 2.7.2.