Skip to content
MediumVulnerability

CVE-2022-41899: TensorFlow SdcaOptimizer assertion failure from rank-invalid dense_features

Identifier
CVE-2022-41899
Published
Record updated
View JSON
Affected
  • tensorflow < 2.8.4, fixed in 2.8.4, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.3, fixed in 2.9.3, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.10.0, < 2.10.1, fixed in 2.10.1, released November 16, 2022, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2022-41899 affects TensorFlow. Passing inputs `dense_features` or `example_state_data` that are not of rank 2 triggers a `CHECK` failure in `SdcaOptimizer`. The source lists TensorFlow 2.10.1, 2.9.3 and 2.8.4 as affected and still within supported range.

Mitigation

The patch is GitHub commit 80ff197d03db2a70c6a111f97dcdacad1b0babfa. The fix will be included in TensorFlow 2.11, and the commit will also be cherry-picked to TensorFlow 2.10.1, 2.9.3 and 2.8.4.