Skip to content
MediumVulnerability

CVE-2022-23568: Tensorflow denial of service via integer overflow in AddManySparseToTensorsMap

Identifier
CVE-2022-23568
Published
Record updated
View JSON
Affected
  • tensorflow < 2.5.3, fixed in 2.5.3, released February 2, 2022, 1 day before disclosure
  • tensorflow >= 2.6.0, < 2.6.3, fixed in 2.6.3, released February 2, 2022, 1 day before disclosure
  • tensorflow = 2.7.0, fixed in 2.7.1, released February 2, 2022, 1 day before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.8%

Summary

TensorFlow's implementation of `AddManySparseToTensorsMap` is vulnerable to an integer overflow. The overflow causes a `CHECK`-fail when new `TensorShape` objects are built, enabling a denial of service through an assert failure. The flaw stems from missing validation of input tensor shapes and from constructing a large `TensorShape` directly from user-provided dimensions.

Mitigation

Fixed in TensorFlow 2.8.0. The fix will also be cherry-picked to TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3.