Skip to content
MediumVulnerability

CVE-2022-41908: TensorFlow is an open source platform for machine learning. An input `token` that is not a UTF-8 bytestring will…

Identifier
CVE-2022-41908
Published
Record updated
View JSON
Affected
  • tensorflow < 2.8.4, fixed in 2.8.4, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.3, fixed in 2.9.3, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.10.0, < 2.10.1, fixed in 2.10.1, released November 16, 2022, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2022-41908 affects TensorFlow. A `token` input that is not a UTF-8 bytestring triggers a `CHECK` fail in `tf.raw_ops.PyFunc`. The issue is tracked by GHSA-mv77-9g28-cwg3 and classified as CWE-20, Improper Input Validation.

Mitigation

Patched in GitHub commit 9f03a9d3bafe902c1e6beb105b2f24172f238645. The fix will be included in TensorFlow 2.11, and the commit will also be cherry-picked to TensorFlow 2.10.1, 2.9.3, and 2.8.4, which the source says are also affected and still supported.