Skip to content
MediumVulnerability

CVE-2022-29193: TensorFlow denial of service through tf.raw_ops.TensorSummaryV2 input validation

Identifier
CVE-2022-29193
Published
Record updated
View JSON
Affected
  • tensorflow < 2.6.4, fixed in 2.6.4, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.7.0, < 2.7.2, fixed in 2.7.2, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 5 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

CVE-2022-29193 affects TensorFlow versions prior to 2.9.0, 2.8.1, 2.7.2, and 2.6.4. The implementation of `tf.raw_ops.TensorSummaryV2` does not fully validate its input arguments, which leads to a `CHECK`-failure. An attacker can trigger this failure to cause a denial of service. The CWE is CWE-20, Improper Input Validation.

Mitigation

Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.