Skip to content
HighVulnerabilityLLM-specific

CVE-2025-48956: vLLM denial of service through oversized HTTP GET request header

Identifier
CVE-2025-48956
Published
Record updated
View JSON
Affected
  • vllm >= 0.1.0, < 0.10.1.1
Fixed in
0.10.1.1
  • released August 20, 2025, 1 day before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.6%

Summary

CVE-2025-48956 affects vLLM, an inference and serving engine for large language models, from 0.1.0 to before 0.10.1.1. A single HTTP GET request with an extremely large header, sent to an HTTP endpoint, triggers a Denial of Service that exhausts server memory and can crash the server or make it unresponsive. No authentication is required, so any remote user can exploit it.

Mitigation

Fixed in 0.10.1.1.