Skip to content
HighVulnerabilityLLM-specific

CVE-2025-53107: @cyanheads/git-mcp-server command injection via unsanitized input

Identifier
CVE-2025-53107
Published
Record updated
View JSON
Affected
  • @cyanheads/git-mcp-server <= 2.1.4
Fixed in
2.1.5
  • released June 29, 2025, 2 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
24.5%

Summary

@cyanheads/git-mcp-server, an MCP server for Git repositories, prior to version 2.1.5 has a command injection flaw. Unsanitized input parameters are passed into a child_process.exec call, so an attacker can inject shell metacharacters such as |, >, and && to run arbitrary system commands with the server process's privileges, potentially leading to remote code execution. An MCP client can also be steered into this through indirect prompt injection when asked to read git logs.

Mitigation

This issue has been patched in version 2.1.5.