Skip to content
CriticalVulnerability

CVE-2023-43654: TorchServe lacks input validation enabling remote file writes

Identifier
CVE-2023-43654
Published
Record updated
View JSON
Affected
  • torchserve >= 0.1.0, < 0.8.2
Fixed in
0.8.2
  • released August 28, 2023, 32 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
42.5%

Summary

TorchServe's default configuration lacks proper input validation, so third parties can trigger remote HTTP download requests and write files to disk. The flaw affects versions 0.1.0 through 0.8.1 and could compromise system integrity and sensitive data.

Mitigation

Users are advised to upgrade to TorchServe 0.8.2, which includes a pull request (PR #2534) that warns when the default allowed_urls value is used. The source states there are no known workarounds.