Skip to content
HighVulnerabilityLLM-specific

CVE-2025-61592: Cursor CLI remote code execution via malicious repository config

Identifier
CVE-2025-61592
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2025-61592 affects Cursor, a code editor built for programming with AI, in versions 1.7 and below. The Cursor CLI automatically loads project-specific configuration from <project>/.cursor/cli.json, and this can override certain global settings. A user running the CLI inside a malicious repository can be exposed to Remote Code Execution when that configuration permits shell commands and prompt injection is delivered through project Rules at <project>/.cursor/rules/rule.mdc or other mechanisms.

Mitigation

Fixed by patch 2025.09.17-25b418f. As of October 3, 2025 there is no release version.