Skip to content
HighVulnerability

CVE-2021-37635: TensorFlow out-of-bounds heap access in sparse reduction operations

Identifier
CVE-2021-37635
Published
Record updated
View JSON
Affected
  • tensorflow < 2.3.4, fixed in 2.3.4, released August 10, 2021, 3 days before disclosure
  • tensorflow >= 2.4.0, < 2.4.3, fixed in 2.4.3, released August 10, 2021, 3 days before disclosure
  • tensorflow = 2.5.0, fixed in 2.5.1, released August 10, 2021, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

CVE-2021-37635 affects TensorFlow versions where the sparse reduction operations do not validate reduction groups or indices against the input tensor bounds. This can trigger out-of-bounds accesses to heap-allocated data.

Mitigation

The issue is patched in GitHub commit 87158f43f05f2720a374f3e6d22a7aaa3a33f750. The fix will be included in TensorFlow 2.6.0, and the commit will be cherry-picked to TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4.