Skip to content
CriticalVulnerabilityLLM-specific

CVE-2025-65099: Claude Code code execution via Yarn plugins in untrusted directories

Identifier
CVE-2025-65099
Published
Record updated
View JSON
Affected
  • @anthropic-ai/claude-code < 1.0.39
Fixed in
1.0.39
  • released July 1, 2025, 141 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2025-65099 affects Claude Code before version 1.0.39 when it runs on a machine with Yarn 3.0 or above. A project's yarn plugins could execute code before the user accepted the startup trust dialog, provided the user started Claude Code in an untrusted directory.

Mitigation

This issue has been patched in version 1.0.39.