Skip to content
MediumVulnerability

CVE-2022-41910: TensorFlow out-of-bounds read in MakeGrapplerFunctionItem via input sizes

Identifier
CVE-2022-41910
Published
Record updated
View JSON
Affected
  • tensorflow < 2.8.4, fixed in 2.8.4, released November 16, 2022, 21 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.3, fixed in 2.9.3, released November 16, 2022, 21 days before disclosure
  • tensorflow >= 2.10.0, < 2.10.1, fixed in 2.10.1, released November 16, 2022, 21 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.4%

Summary

CVE-2022-41910 affects TensorFlow's MakeGrapplerFunctionItem function, which takes arguments that set the sizes of inputs and outputs. When the given inputs are greater than or equal to the output sizes, it triggers an out-of-bounds memory read or a crash. The weakness is classified as CWE-125, Out-of-bounds Read.

Mitigation

Patched in GitHub commit a65411a1d69edfb16b25907ffb8f73556ce36bb7. The fix will be included in TensorFlow 2.11.0, and the commit will also be cherry-picked to TensorFlow 2.8.4, 2.9.3, and 2.10.1.