Skip to content
HighVulnerabilityLLM-specific

CVE-2025-64107: Cursor editor command execution via backslash path manipulation on Windows

Identifier
CVE-2025-64107
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.4%

Summary

CVE-2025-64107 affects Cursor, a code editor built for programming with AI, in versions 1.7.52 and below. Cursor checks path manipulation that uses forward slashes, such as ./.cursor/./././././mcp.json, and requires human approval before completing the operation. The same manipulation with backslashes was not detected, so an attacker who already had prompt injection or another level of control could overwrite sensitive editor files without approval on Windows machines, which may lead to RCE.

Mitigation

Fixed in version 2.0.