MediumVulnerability
CVE-2021-41200: TensorFlow crash in tf.summary.create_file_writer with non-scalar arguments
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2021-41200
- Published
- Record updated
- Affected
- tensorflow >= 2.6.0, < 2.6.1, fixed in 2.6.1, released November 1, 2021, 5 days before disclosure
- tensorflow >= 2.5.0, < 2.5.2, fixed in 2.5.2, released November 1, 2021, 5 days before disclosure
- tensorflow < 2.4.4, fixed in 2.4.4, released November 1, 2021, 5 days before disclosure
- and 6 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.2%
Summary
CVE-2021-41200 affects TensorFlow. In affected versions, calling `tf.summary.create_file_writer` with non-scalar arguments causes a crash due to a `CHECK`-fail. The weakness is classified as CWE-617 (Reachable Assertion).
Mitigation
The fix will be included in TensorFlow 2.7.0. The commit will also be cherrypicked to TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database