HighVulnerabilityLLM-specific
CVE-2025-59944: Cursor IDE case-sensitive file protection bypass allowing code execution
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2025-59944
- Published
- Record updated
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.5%
Summary
CVE-2025-59944 affects Cursor, an AI-assisted code editor, in versions 1.6.23 and below. Its protection for sensitive files such as */.cursor/mcp.json uses case-sensitive checks, so on case-insensitive filesystems an attacker can use prompt injection to modify those files and achieve remote code execution. The source classifies the weakness as CWE-178, Improper Handling of Case Sensitivity.
Mitigation
This issue is fixed in version 1.7.
Coverage
News, research and other items that mention CVE-2025-59944.
- Cursor security: top 10 attacks and what each one actually brokeAdversa AI Blog · 2026-11-03
Related items
- InfoTop agent skill security resources — November 2026Similar attack · Adversa AI Blog
- InfoHow to Turn AI Red Team Findings Into Runtime ControlsSimilar attack · Straiker Blog
- MediumDocker Sandboxes vulnerability lets AI agents access sensitive files outside their sandbox (CVE-2026-103916) | Endor LabsSimilar attack · Endor Labs Blog
- MediumFree the Model, Sell the Gateway: Prompt Adware hidden in Jailbreak BundlesSimilar attack · Check Point Research
- InfoRight Tool, Wrong Parameters: Defending LLM Agents Against Parameter PoisoningSimilar attack · Arxiv (cs.CR + cs.CL + cs.LG)