Skip to content
LowVulnerability

CVE-2021-29610: TensorFlow heap underflow via invalid axis in QuantizeAndDequantizeV2

Identifier
CVE-2021-29610
Published
Record updated
View JSON
Affected
  • tensorflow < 2.1.4, fixed in 2.1.4, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.2.0, < 2.2.3, fixed in 2.2.3, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
  • and 9 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

TensorFlow's `tf.raw_ops.QuantizeAndDequantizeV2` accepts invalid `axis` values because its validation uses `||` to combine two conditions. When `axis_ < -1`, the `OP_REQUIRES` check still passes, and this value causes a heap underflow. Attackers can use it to read and write other data on the heap.

Mitigation

The fix will be included in TensorFlow 2.5.0. The commit will also be cherry-picked to TensorFlow 2.4.2, 2.3.3, 2.2.3 and 2.1.4, which are also affected and still in supported range.