HighVulnerability
CVE-2023-27579: TensorFlow tflite filter_input_channel below 1 causes FPE
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2023-27579
- Published
- Record updated
- Affected
- tensorflow < 2.11.1
- tensorflow-cpu < 2.11.1
- tensorflow-gpu < 2.11.1
- Fixed in
- 2.11.1
- tensorflow 2.11.1 released March 20, 2023, 5 days before disclosure
- tensorflow-cpu 2.11.1 released March 20, 2023, 5 days before disclosure
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.4%
Summary
TensorFlow, an open source machine learning platform, has a flaw (CWE-697, Incorrect Comparison) in which constructing a tflite model with the parameter `filter_input_channel` set to less than 1 causes an FPE. The issue is tracked as CVE-2023-27579, published 03/24/2023 by GitHub, Inc.
Mitigation
This issue has been patched in version 2.12. TensorFlow will also cherrypick the fix commit on TensorFlow 2.11.1.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database