LowVulnerability
CVE-2021-29603: TensorFlow is an end-to-end open source platform for machine learning. A specially crafted TFLite model could trigger…
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2021-29603
- Published
- Record updated
- Affected
- tensorflow < 2.1.4, fixed in 2.1.4, released June 15, 2021, 31 days after disclosure
- tensorflow >= 2.2.0, < 2.2.3, fixed in 2.2.3, released June 15, 2021, 31 days after disclosure
- tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
- and 9 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.2%
Summary
TensorFlow, an open source machine learning platform, has an out-of-bounds heap write in the TFLite implementation of `ArgMin`/`ArgMax`. A specially crafted TFLite model can trigger it when `axis_value` falls outside the range between 0 and `NumDimensions(input)`, because the guarding `if` never evaluates true and code writes past the last valid element of `output_dims->data`.
Mitigation
The fix will be included in TensorFlow 2.5.0. The commit will also be cherry-picked to TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, which are also affected and still in supported range.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database