Skip to content
CriticalVulnerabilityLLM-specific

CVE-2024-8309: langchain GraphCypherQAChain SQL injection through prompt injection

Identifier
CVE-2024-8309
Published
Record updated
View JSON
Affected
  • langchain < 0.2.0, fixed in 0.2.0, released May 17, 2024, 165 days before disclosure
  • langchain-community >= 0.2.0, < 0.2.19, fixed in 0.2.19, released November 12, 2024, 14 days after disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
13.7%

Summary

CVE-2024-8309 affects the GraphCypherQAChain class of langchain-ai/langchain version 0.2.5. Attackers can use prompt injection to trigger SQL injection, allowing them to create, update, or delete nodes and relationships without authorization, extract sensitive data, and disrupt service. The flaw can also reach data across tenants in multi-tenant environments and compromise database integrity.

Mitigation

The source does not state a fix yet. Check the original advisory for updates.