Skip to content
HighVulnerabilityLLM-specific

CVE-2025-64110: Cursor logic bug lets agent read files protected by cursorignore

Identifier
CVE-2025-64110
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.4%

Summary

CVE-2025-64110 affects Cursor, a code editor built for programming with AI, in versions 1.7.23 and below. A logic bug lets a malicious agent read sensitive files that should be protected via cursorignore. An attacker who has already achieved prompt injection, or a malicious model, could create a new cursorignore file that invalidates the configuration of pre-existing ones.

Mitigation

This issue is fixed in version 2.0.