Skip to content
MediumVulnerability

CVE-2022-41897: TensorFlow crash in FractionMaxPoolGrad with oversized pooling sequence inputs

Identifier
CVE-2022-41897
Published
Record updated
View JSON
Affected
  • tensorflow < 2.8.4, fixed in 2.8.4, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.3, fixed in 2.9.3, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.10.0, < 2.10.1, fixed in 2.10.1, released November 16, 2022, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2022-41897 affects TensorFlow, an open source machine learning platform. If `FractionMaxPoolGrad` receives outsize inputs `row_pooling_sequence` and `col_pooling_sequence`, TensorFlow crashes. The weakness is classified as CWE-125, Out-of-bounds Read.

Mitigation

The issue is patched in GitHub commit d71090c3e5ca325bdf4b02eb236cfb3ee823e927. The fix will be included in TensorFlow 2.11, and the commit will be cherrypicked to TensorFlow 2.10.1, 2.9.3, and 2.8.4, which are also affected and still in supported range.