HighVulnerability
CVE-2020-15208: tensorflow-lite out-of-bounds read and write from tensor dimension check
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2020-15208
- Published
- Record updated
- Affected
- tensorflow < 1.15.4, fixed in 1.15.4, released September 24, 2020, 1 day before disclosure
- tensorflow >= 2.0.0, < 2.0.3, fixed in 2.0.3, released September 24, 2020, 1 day before disclosure
- tensorflow >= 2.1.0, < 2.1.2, fixed in 2.1.2, released September 24, 2020, 1 day before disclosure
- and 12 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.9%
Summary
TensorFlow Lite versions before 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1 determine the common dimension size of two tensors with a DCHECK that is a no-op outside debug builds, and the function always returns the first tensor's dimension. An attacker can craft tensors where that value exceeds the second tensor's, causing out-of-bounds reads and writes because the interpreter assumes both tensors hold enough data.
Mitigation
The issue is patched in commit 8ee24e7949a203d234489f9da2c5bf45a7d5157d and released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database