Skip to content
HighVulnerability

GHSA-2p9h-rqjw-gm92: n8n Vulnerable to Stored XSS via Various Nodes

Published
Record updated
View JSON
Affected
  • n8n >= 2.10.0, < 2.10.1, fixed in 2.10.1, released February 25, 2026, on the day of disclosure
  • n8n >= 2.0.0, < 2.9.3, fixed in 2.9.3, released February 25, 2026, on the day of disclosure
  • n8n < 1.123.22, fixed in 1.123.22, released February 25, 2026, on the day of disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

An authenticated user who can create or modify workflows in n8n can inject arbitrary scripts into pages rendered by the application through the Form Trigger, Chat Trigger, Send & Wait, Webhook and Chat nodes. Injected scripts run in the browser of any user who visits the affected page, enabling session hijacking and account takeover.

Mitigation

Fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22; users should upgrade to one of these or later. If upgrading is not immediately possible, limit workflow creation and editing permissions to fully trusted users only, and disable the Webhook node by adding `n8n-nodes-base.webhook` to the `NODES_EXCLUDE` environment variable. The source states these workarounds do not fully remediate the risk and should be used only as short-term measures.