Skip to content
CriticalVulnerabilityLLM-specific

CVE-2025-32444: vLLM remote code execution through pickle deserialization over ZeroMQ sockets

Identifier
CVE-2025-32444
Published
Record updated
View JSON
Affected
  • vllm >= 0.6.5, < 0.8.5
Fixed in
0.8.5
  • released April 28, 2025, 2 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
1.8%

Summary

CVE-2025-32444 affects vLLM versions starting from 0.6.5 and prior to 0.8.5 when the vLLM integration with mooncake is in use. Those versions use pickle-based serialization over unsecured ZeroMQ sockets, which are set to listen on all network interfaces, allowing remote code execution by an attacker who can reach them. vLLM instances without the mooncake integration are not vulnerable.

Mitigation

Fixed in 0.8.5.