Skip to content
MediumVulnerability

CVE-2022-23576: Tensorflow integer overflow in OpLevelCostEstimator::CalculateOutputSize

Identifier
CVE-2022-23576
Published
Record updated
View JSON
Affected
  • tensorflow < 2.5.3, fixed in 2.5.3, released February 2, 2022, 3 days before disclosure
  • tensorflow >= 2.6.0, < 2.6.3, fixed in 2.6.3, released February 2, 2022, 3 days before disclosure
  • tensorflow = 2.7.0, fixed in 2.7.1, released February 2, 2022, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.8%

Summary

CVE-2022-23576 affects TensorFlow's `OpLevelCostEstimator::CalculateOutputSize`, which is vulnerable to an integer overflow. An attacker who can create an operation involving tensors with a large enough number of elements can trigger it, either through many dimensions in `output_shape.dim()` or through a few dimensions that are large enough to overflow the multiplication.

Mitigation

The fix will be included in TensorFlow 2.8.0. The commit will also be cherry-picked to TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, which are also affected and still in the supported range.