Skip to content
HighVulnerabilityLLM-specific

CVE-2025-61590: Cursor remote code execution through Visual Studio Code workspaces

Identifier
CVE-2025-61590
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

Cursor versions 1.6 and below are vulnerable to remote code execution through Visual Studio Code workspace files. An attacker who hijacks the victim's chat context, for example via a compromised MCP server, can use prompt injection to make the Cursor Agent write to a .code-workspace file. This bypasses the fix for CVE-2025-54130 by modifying workspace settings, which leads to RCE.

Mitigation

Fixed in version 1.7.