Skip to content
MediumVulnerabilityLLM-specific

CVE-2025-54558: OpenAI Codex CLI auto-approves ripgrep execution with dangerous flags

Identifier
CVE-2025-54558
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

CVE-2025-54558 affects OpenAI Codex CLI versions before 0.9.0, which auto-approve execution of ripgrep (rg) even when the --pre, --hostname-bin, --search-zip or -z flag is present. The weakness is classified as CWE-829, Inclusion of Functionality from Untrusted Control Sphere. NVD has not yet provided an assessment.

Mitigation

Fixed in 0.9.0. The fix is in commit 6cf4b96f9dbbef8a94acc1ff703eb118481514d8 and pull request openai/codex#1644, covering the change from rust-v0.8.0 to rust-v0.9.0.