Skip to content
CriticalVulnerabilityLLM-specific

CVE-2025-29783: vLLM unsafe deserialization over ZMQ/TCP when using Mooncake

Identifier
CVE-2025-29783
Published
Record updated
View JSON
Affected
  • vllm >= 0.6.5, < 0.8.0
Fixed in
0.8.0
  • released March 18, 2025, 1 day before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.7%

Summary

CVE-2025-29783 affects vLLM when it is configured to use Mooncake. Unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces lets attackers execute remote code on distributed hosts. The flaw impacts any deployment that uses Mooncake to distribute KV across distributed hosts.

Mitigation

Fixed in 0.8.0.