Skip to content
HighVulnerabilityLLM-specific

CVE-2025-55284: Claude Code confirmation prompt bypass allows network file exfiltration

Identifier
CVE-2025-55284
Published
Record updated
View JSON
Affected
  • @anthropic-ai/claude-code < 1.0.4
Fixed in
1.0.4
  • released May 28, 2025, 80 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.6%

Summary

Claude Code versions prior to 1.0.4 contain an overly broad allowlist of safe commands. This lets an attacker bypass confirmation prompts to read a file and send its contents over the network without user approval. Reliable exploitation requires the ability to insert untrusted content into a Claude Code context window.

Mitigation

Fixed in version 1.0.4. Users on standard auto-update received the fix automatically after release. Versions prior to 1.0.24 are deprecated and have been forced to update, so current users are unaffected.