MediumVulnerability
CVE-2025-58401: Obsidian GitHub Copilot Plugin stores GitHub API token in cleartext
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2025-58401
- Published
- Record updated
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.1%
Summary
CVE-2025-58401 affects the Obsidian GitHub Copilot Plugin in versions prior to 1.1.7. The plugin stores the GitHub API token in cleartext form (CWE-312), so an attacker may perform unauthorized operations on the linked GitHub account. JPCERT/CC assigned a CVSS 4.0 score of 5.1 (MEDIUM), and NVD had not yet provided an assessment.
Mitigation
Fixed in 1.1.7 (https://github.com/Pierrad/obsidian-github-copilot/releases/tag/1.1.7).