Skip to content
CriticalVulnerabilityLLM-specific

CVE-2024-4181: llama_index RunGptLLM command injection via eval in LLM provider responses

Identifier
CVE-2024-4181
Published
Record updated
View JSON
Affected
  • llama-index < 0.10.13, fixed in 0.10.13, released February 26, 2024, 80 days before disclosure
  • llama-index-llms-rungpt < 0.1.3, fixed in 0.1.3, released February 24, 2024, 82 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
2.1%

Summary

CVE-2024-4181 is a command injection flaw in the RunGptLLM class of the llama_index library, version 0.9.47, which the RunGpt framework from JinaAI uses to connect to LLMs. The class improperly uses the eval function, so a malicious or compromised LLM hosting provider can execute arbitrary commands on the client's machine and gain full control over it.

Mitigation

Fixed in version 0.10.13.