Skip to content
HighVulnerability

CVE-2025-61591: Cursor command injection via MCP OAuth with untrusted server

Identifier
CVE-2025-61591
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
1.2%

Summary

CVE-2025-61591 affects Cursor, a code editor built for programming with AI, in versions 1.7 and below. When MCP uses OAuth authentication with an untrusted MCP server, an attacker can impersonate that server and return crafted commands during interaction, enabling command injection. Chained with an untrusted MCP service via OAuth, the flaw could let the agent execute arbitrary code on the host with full user privileges.

Mitigation

This issue does not currently have a fixed release version, but there is a patch, 2025.09.17-25b418f.