Skip to content
HighVulnerabilityLLM-specific

CVE-2026-59823: LiteLLM Proxy server-side request forgery through user_config api_base

Identifier
CVE-2026-59823
Published
Record updated
View JSON
Affected
  • litellm <= 1.83.8
Fixed in
1.83.9
  • released April 16, 2026, 152 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.4%

Summary

LiteLLM, an AI Gateway proxy for calling LLM APIs, is affected before version 1.83.9. An authenticated caller holding a valid virtual key can nest api_base inside the user_config request body, which bypasses is_request_body_safe because that check blocks only top-level api_base and base_url. Since user_config builds the outbound router, the caller can redirect server-side requests to an internal or external host of their choosing and reach endpoints they could not otherwise access.

Mitigation

Fixed in 1.83.9.