Skip to content
MediumVulnerability

CVE-2022-36015: TensorFlow crash in RangeSize when values exceed int64_t

Identifier
CVE-2022-36015
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.7%

Summary

TensorFlow crashes when the `RangeSize` function receives values that do not fit into an `int64_t`, a flaw the source classifies as CWE-190 (Integer Overflow or Wraparound). The issue is tracked as CVE-2022-36015 and was published by NVD on 09/16/2022. The source names TensorFlow 2.9.1, 2.8.1 and 2.7.2 as also affected.

Mitigation

Patched in GitHub commit 37e64539cd29fcfb814c4451152a60f5d107b0f0, included in TensorFlow 2.10.0. The commit will also be cherrypicked to TensorFlow 2.9.1, 2.8.1 and 2.7.2.