Skip to content
HighVulnerabilityLLM-specific

CVE-2026-18733: Amazon Strands Agents Tools prompt injection in shell tool

Identifier
CVE-2026-18733
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.6%

Summary

Amazon Strands Agents Tools before 0.8.0 contains a prompt injection vulnerability in its shell tool. A crafted prompt that sets the non_interactive parameter to true bypasses the human consent gate, allowing remote actors to execute arbitrary operating system commands on the agent's host. The CNA, AMZN, rates it CVSS 4.0 7.5 (HIGH), and NVD has not yet provided an assessment.

Mitigation

To remediate this issue, users should upgrade to version 0.8.0.