CVE-2020-15211: TensorFlow Lite out-of-bounds read and write via negative tensor index
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2020-15211
- Published
- Record updated
- Affected
- tensorflow < 1.15.4, fixed in 1.15.4, released September 24, 2020, 1 day before disclosure
- tensorflow >= 2.0.0, < 2.0.3, fixed in 2.0.3, released September 24, 2020, 1 day before disclosure
- tensorflow >= 2.1.0, < 2.1.2, fixed in 2.1.2, released September 24, 2020, 1 day before disclosure
- and 12 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.9%
Summary
CVE-2020-15211 affects TensorFlow Lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1. The flatbuffer model format treats a tensor index of -1 as an optional tensor, but validation accepts it for any operator, including outputs. This lets a crafted model read and write outside the bounds of heap-allocated arrays, at a specific offset from the start of those arrays, giving limited read and write primitives.
Mitigation
Fixed in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, via commits 46d5b0852, 00302787b7, e11f5558, cd31fd0ce, 1970c21 and fff2c83. Workaround: add a custom Verifier to the model loading code so that only operators accepting optional inputs use the -1 value, and only for the tensors they expect to be optional. The source advises upgrading to the patched code instead, since the allow-list approach is error-prone.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database