Skip to content
CriticalVulnerability

CVE-2023-46302: Apache Submarine unsafe YAML deserialization in REST request handling

Identifier
CVE-2023-46302
Published
Record updated
View JSON
Affected
  • apache-submarine >= 0.7.0, < 0.8.0
Fixed in
0.8.0
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
1.8%

Summary

Apache Submarine versions from 0.7.0 before 0.8.0 contain a flaw in YAML handling. The YamlEntityProvider in submarine-server/server-core/src/main/java/org/apache/submarine/server/utils/YamlUtils.java unmarshals user-supplied YAML requests through its readFrom method, and the bug is tied to snakeyaml, as described in CVE-2022-1471.

Mitigation

Fixed in 0.8.0, which replaces snakeyaml with jackson-dataformat-yaml; users are recommended to upgrade to version 0.8.0. If upgrading is not possible, cherry-pick PR https://github.com/apache/submarine/pull/1054 and rebuild the submarine-server image.