Skip to content
CriticalVulnerabilityLLM-specific

CVE-2025-59828: Claude Code trust dialog bypass through Yarn plugin auto-execution

Identifier
CVE-2025-59828
Published
Record updated
View JSON
Affected
  • @anthropic-ai/claude-code < 1.0.39
Fixed in
1.0.39
  • released July 1, 2025, 85 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.4%

Summary

CVE-2025-59828 affects Claude Code before version 1.0.39 when used with Yarn 2.0+. Yarn plugins execute automatically when yarn --version runs, which can bypass the directory trust dialog because plugins run before the user accepts the risks of an untrusted directory. Users of Yarn Classic were not affected.

Mitigation

This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update received the fix automatically. Users performing manual updates are advised to update to the latest version.